Changing your username

  • Kennon avataradmin
    Kennon 13 Sep 2010 18:07
    We've added a functionality to the My Pond>Profile page that will allow users to change their username, since this is an issue we resolve pretty frequently.

    If you'd like to change your username, go to My Pond>Profile>Username and enter your new one in the box provided.

    But remember, measure twice, cut once, this feature will only work one time.


    LUXORPYRAMID 13 Sep 2010 20:26
    I just want to add that when I changed my username from LUXOR to LUXORPYRAMID some weeks ago the FTP username also changed from LUXOR to LUXORPYRAMID. I uploaded a few clips that ended up in "limbo zone" because the system was accepting my old username. I realized what was happening and I change the FTP username to the new one.
  • vadervideo avatar
    vadervideo 26 Sep 2010 12:34
    Excellent point Luxor - totally didn't even think of that, as they are actually interconnected.
  • mark29 avatar
    mark29 15 Jan 2011 14:11
    I tried this today and it said the username I wanted was already taken. A check of the artists list revealled it was not in use. It is a rather unusual name. Any help?
  • MovingImages avatar
    MovingImages 16 Jan 2011 22:49
    So, once we change usernames, we need to change FTP login immediately to match? What is the window, or can we use the old login indefinitely?
  • ionescu avatar
    ionescu 17 Feb 2011 08:45
    Great feature, thank you !
  • AcmeStudios avatar
    AcmeStudios 15 Mar 2011 16:51
    I changed today, and I updated my ftp login, but it fails. Kennon?
  • Kennon avataradmin
    Kennon 15 Mar 2011 19:13
    Hi Acme

    It sometimes takes time for the ftp to associate with the new username, give it 24 hours or so to associate your FTP with the new name.


    Pond5 Team
  • AcmeStudios avatar
    AcmeStudios 16 Mar 2011 15:41
    Hi Kennon

    Thanks for the info - I tried again before replying - still No Joy. I'll try again later today.
  • AcmeStudios avatar
    AcmeStudios 16 Mar 2011 19:08

    It's still not working. Frustrated.